Unable to login to Retrium
Incident Report for Retrium
Resolved
This incident has been resolved.
Posted 6 months ago. Dec 13, 2018 - 13:42 EST
Update
We are continuing to investigate this issue.
Posted 6 months ago. Dec 13, 2018 - 13:37 EST
Investigating
Users are unable to login to Retrium. We are currently investigating the reason.
Posted 6 months ago. Dec 13, 2018 - 13:37 EST
This incident affected: Authentication System.