Free trial accounts showing as expired
Incident Report for Retrium
Resolved
This incident has been resolved.
Posted over 3 years ago. Mar 14, 2016 - 10:56 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted over 3 years ago. Mar 14, 2016 - 10:21 EDT
Investigating
Any account on a free trial that has run at least one retrospective is showing as if their free trial has expired. This is preventing free trial accounts from running retrospectives. We are investigating now.
Posted over 3 years ago. Mar 14, 2016 - 10:12 EDT