Retrium application is slow to respond or not loading
Incident Report for Retrium
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 08, 2019 - 11:29 EDT
Identified
We've identified the issue and are working on a fix now.
Posted 2 months ago. Aug 08, 2019 - 11:17 EDT
Investigating
The Retrium app is slow to respond for some users (or not responding at all). We are currently investigating the issue and will provide updates regularly.
Posted 2 months ago. Aug 08, 2019 - 11:07 EDT
This incident affected: Retrospectives.