Password reset is broken
Incident Report for Retrium
Resolved
This incident has been resolved.
Posted 9 months ago. Jul 27, 2018 - 15:21 EDT
Update
We've identified and fixed resetting your password.
Posted 9 months ago. Jul 27, 2018 - 15:21 EDT
Investigating
Resetting your password is currently broken. If you try to reset your password, you will get locked out of your account. We are investigating and will keep you updated here.
Posted 9 months ago. Jul 26, 2018 - 11:18 EDT
This incident affected: Authentication System.