SSL certificate expired
Incident Report for Retrium
Resolved
Our site is back up with a new certificate.
Posted about 3 years ago. Jun 20, 2016 - 11:14 EDT
Update
While we are investigating, please use retrium.com instead of www.retrium.com. the former works fine.
Posted about 3 years ago. Jun 20, 2016 - 10:59 EDT
Identified
Our SSL certificate expired and it's giving a warning in most modern browsers. It is safe to ignore the warning.
Posted about 3 years ago. Jun 20, 2016 - 10:54 EDT