Outbound emails are delayed
Incident Report for Retrium
Resolved
This incident has been resolved and all emails are sending as normal.
Posted over 1 year ago. May 15, 2018 - 15:22 EDT
Identified
Our transactional email platform is experiencing delays in sending outbound email messages. Emails such as verifying your account and inviting new users are delayed as a result.
Posted over 1 year ago. May 15, 2018 - 14:39 EDT
This incident affected: Email.