Signup process is down
Incident Report for Retrium
Resolved
Signups works again now that we've fixed the list ID issue.
Posted over 3 years ago. Feb 23, 2016 - 14:40 EST
Identified
We've identified the issue. Has to do with an incorrect list ID token internally.
Posted over 3 years ago. Feb 23, 2016 - 14:17 EST
Investigating
Our signup page is currently broken and you are not able to currently sign up.
Posted over 3 years ago. Feb 23, 2016 - 14:15 EST