Going to http://www.retrium.com redirects to an invalid URL
Incident Report for Retrium
Resolved
http://www.retrium.com now redirects appropriately. All URLs are working as expected.
Posted almost 3 years ago. Aug 30, 2016 - 12:40 EDT
Investigating
Please use https://www.retrium.com while we investigate. (Note the https prefix)
Posted almost 3 years ago. Aug 30, 2016 - 12:11 EDT