Scheduled Maintenance

Incident Report for Retrium

Resolved

The maintenance is now complete.
Posted Oct 22, 2022 - 11:10 EDT

Investigating

We are deploying an update that requires a short downtime.
Posted Oct 22, 2022 - 09:47 EDT
This incident affected: Website, Retrospectives, Email, and Authentication.