AWS Outage Affecting Application Uptime

Incident Report for Retrium

Resolved

The issue appears to be resolved at this time.
Posted Oct 21, 2025 - 07:30 EDT

Monitoring

We're experiencing intermittent disruptions due to an ongoing AWS infrastructure outage affecting database connectivity. Users may see delays or timeouts in real-time data. Our team is monitoring closely, but full resolution depends on AWS restoring services. Updates to follow.
Posted Oct 20, 2025 - 15:50 EDT
This incident affected: Retrospectives and Authentication.