Server instability
Incident Report for Retrium
Resolved
This incident has been resolved.
Posted Feb 20, 2024 - 12:34 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 20, 2024 - 10:07 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 20, 2024 - 10:05 EST
This incident affected: Retrospectives, Subscriptions and billing, and Authentication.