Email System Outage

Incident Report for Retrium

Resolved

This incident has been resolved.
Posted Jul 27, 2026 - 16:26 EDT

Investigating

There is currently an outage for email delivery systems. This will affect users attempting to verify emails, reset passwords, or any other systems that require the use of emails sent from Retrium.
Posted Jul 27, 2026 - 07:27 EDT
This incident affected: Email.